Proposal: add ifM and whenM to Control.Monad
Brandon Allbery
allbery.b at gmail.com
Mon Apr 21 12:55:07 UTC 2014
On Mon, Apr 21, 2014 at 5:35 AM, Mario Pastorelli <
pastorelli.mario at gmail.com> wrote:
> On 04/21/2014 10:41 AM, Simon Hengel wrote:
>
>> A quick heuristic grep over all Hackage packages results in quite a bit
>>> of packages containing the ifM/whenM/unlessM:
>>>
>> But that kind of shows that the "expected" names for those functions are
>> ifM/whenM/unlessM. I would ask the question:
>>
>> Are there any other useful combinators that would be named
>> ifM/whenM/unlessM under the current naming convention?
>>
>> If no, then I'm not entirely convinced that we should decide against
>> what seems to be common intuition here.
>>
>
> Breaking API consistency because a lot of people are already doing it
> doesn't feel right. If they
The API is there to serve its users, not really to dictate to them. If the
common convention is counter to the API structure, perhaps it is the API
that should change.
--
brandon s allbery kf8nh sine nomine associates
allbery.b at gmail.com ballbery at sinenomine.net
unix, openafs, kerberos, infrastructure, xmonad http://sinenomine.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/libraries/attachments/20140421/c246afbe/attachment.html>
More information about the Libraries
mailing list