cabal-install error messages

Harry Garrood harry at
Fri Sep 27 13:52:23 CEST 2013

I recently was trying to `cabal install` (with a sandbox) a package I'd
made, which depends on scotty-0.5.0. Cabal-install was giving me this

$ cabal install
Resolving dependencies...
cabal: Could not resolve dependencies:
trying: multicopter-0.0.1 (user goal)
next goal: scotty (dependency of multicopter-0.0.1)
rejecting: scotty-0.4.6, 0.4.5, 0.4.4, 0.4.3, 0.4.2, 0.4.1, 0.4.0,
0.2.0, 0.1.0, 0.0.1 (conflict: multicopter => scotty>=0.5.0)
Dependency tree exhaustively searched.
Note: when using a sandbox, all packages are required to have consistent
dependencies. Try reinstalling/unregistering the offending packages or
recreating the sandbox.

My first assumption was that scotty, and some other package that my
package depend on, both want different versions of a third package. I
tried removing everything else from the build-depends field, but I got
the same message.

Then I did a `cabal update` which appears to have fixed it.

My question is: Should cabal-install, in this situation, say something
like "I'm not aware of a version 0.5.0 for the 'scotty' package. Try
`cabal update`" instead?

More information about the Libraries mailing list