Data.Type.Equality and coercions

Stijn van Drongelen rhymoid
Wed Oct 9 16:22:35 UTC 2013

On Wed, Oct 9, 2013 at 5:25 PM, Richard Eisenberg <eir at> wrote:

> My slight inclination: rename the Coercible version to `coerceRep`, as it
> really is doing a runtime coercion, as opposed to `coerce`. But, I'm quite
> happy for someone else to have a better idea.

Why not keep the name `coerce` for both functions, and require qualified

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Libraries mailing list