qualification (was: Control.Monad proposal: Add whenJust)

Henning Thielemann lemming at henning-thielemann.de
Sun May 12 20:18:00 CEST 2013

On Sun, 12 May 2013, Ben Millwood wrote:

> If instead of explicit import lists you use qualification, then everyone 
> names the module themselves (no-one wants to write Data.Foldable) and 
> possibly names it different things (my habit is initial letters, until I 
> need to import Data.Text and Data.Traversable...)

I define function names that make sense when being qualified with the 
module name. This way I do not need one-letter abbreviations when 
importing a module. I think a function name like Text.fromString is both 
more readable than T.pack and will not clash with Traversable.

More information about the Libraries mailing list