[commit: unix] master: change notes (1461d21)

Ganesh Sittampalam ganesh at earth.li
Mon Mar 4 20:17:39 CET 2013


On 11/02/2013 08:52, Simon Marlow wrote:

> So a good solution to this would be to have two version bumps: one for
> development (2.7.x.x) and another bump for the final release (
>  Then Cabal can make releases that relax the unix dependency to 2.7,
> which is fine because we'll never make a release of 2.7, it just keeps
> things working during development.

What's the status of this proposal?

As HTTP maintainer I'm strongly in favour of it for all libraries
shipped with GHC including base, as it'd allow me to bump dependencies
for development versions to keep the bleeding edge people happy, whilst
still conforming to the PVP for stable versions.



More information about the Libraries mailing list