Install cabal-install without root

harry voldermort at
Thu Jul 25 13:44:52 CEST 2013

I'm trying to bootstrap cabal-install on a shared system where I don't have
root access. It got stuck on:

Linking Setup ...
Configuring zlib-
Setup: Missing dependency on a foreign library:
* Missing (or bad) header file: zlib.h
* Missing C library: z
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.

So I unpacked zlib-dev into my home dir, and pointed $LIBRARY_PATH to it,
but I'm still getting the same error. Do I need to modify the .cabal file
for every package that I'm trying to install, or is there some way of
telling it globally where to find libraries on non-standard paths?

View this message in context:
Sent from the Haskell - Libraries mailing list archive at

More information about the Libraries mailing list