HP Package Requirements (was: Haskell Platform proposal: Add case-insensitive)

Herbert Valerio Riedel hvr at gnu.org
Sat Jan 12 14:07:12 CET 2013

Roman Cheplyaka <roma-e10UterjXHviB9QmIjCX8w at public.gmane.org> writes:


> There should be a policy regarding standard compliance of the platform
> packages.
> The status quo is that a large part of the platform is not Haskell2010,
> and converting it to Haskell2010 does not seem feasible.
> So the policy seems to be that the platform does not require the
> packages to be H2010 (or H98, for that matter).

Btw, some time ago, I tried to find out what the actual compatibility
requirements were for HP packages, but I could find only the following

More information about the Libraries mailing list