Improving void

John Wiegley johnw at
Tue Aug 6 20:42:58 CEST 2013

>>>>> Edward Kmett <ekmett at> writes:

> I propose we replace it with

> void :: Functor f => f a -> f ()
> void = (() <$)


Edward recently convinced me that 'void' has some hidden costs (over, say, the
idiom of "_ <-"), so I'm in favor of anything that may ameliorate those costs.

John Wiegley
FP Complete                         Haskell tools, training and consulting               johnw on #haskell/

More information about the Libraries mailing list