HP 2013.2 and GHC 7.6.2

Iavor Diatchki iavor.diatchki at gmail.com
Wed Apr 17 17:20:22 CEST 2013


cabal-install 1.16.0 and have some serious bugs that one
encounters rather quickly.  For example, at work I wasted some time until I
figured out that cabal was generating a 'Paths_'  module that does not
compile.   Because of this, you can't even use it to install a newer
version of itself, where the problem is fixed: you have to manually
bootstrap the new version with the script!

I think it would be quite unfortunate to make yet another GHC release that
ships with it, let alone add it to the Haskell platform.



On Wed, Apr 17, 2013 at 7:17 AM, Ian Lynagh <ian at well-typed.com> wrote:

> On Wed, Apr 17, 2013 at 02:48:26PM +0100, Duncan Coutts wrote:
> >
> > In the absence of a GHC-7.6.3, I'm not sure if it's practical for the HP
> > to bump the Cabal version.
> My proposal was 7.6.3 was a minimal release in a very short timeframe,
> to just fix #7748. Any additional changes introduce a possibility of
> regression. If you think that 7.6.2+1.16.0 would be OK, then it sounds
> like the fixes in wouldn't be worth the risk (there are a
> number of GHC fixes that we won't be merging either, for the same
> reason).
> Thanks
> Ian
> _______________________________________________
> ghc-devs mailing list
> ghc-devs at haskell.org
> http://www.haskell.org/mailman/listinfo/ghc-devs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/libraries/attachments/20130417/18a9ef35/attachment.htm>

More information about the Libraries mailing list