Proposal: Control.Concurrent.Async

Lauri Alanko la at
Thu Jun 14 23:54:14 CEST 2012

Quoting "Simon Marlow" <marlowsd at>:
> Naming is obviously up for discussion too.

I feel that "Async" is a bit too generic and doesn't very precisely  
characterize this particular construct. How about "Future", as similar  
things are called in e.g. Alice  
<> and Java  


More information about the Libraries mailing list