Proposal: merge Data.Functor.Coproduct into transformers

Ben Millwood haskell at
Sun Dec 16 12:55:24 CET 2012

On Sun, Dec 16, 2012 at 12:57 AM, Ross Paterson <ross at> wrote:
> On Sat, Dec 15, 2012 at 09:24:48PM +0000, Henning Thielemann wrote:
>> Since I proposed that and became aware of the newtype solution in the
>> meantime, I change my mind to:
>> > data Sum f g a = Sum { getSum :: Either (f a) (g a) }
> OK, let's do that.  It matches the treatment of Product.

Do you mean in name or in implementation? Product is not a newtype, so
the most consistent thing to do would surely be to make Sum not a

(This is not a vote, merely a comment).

More information about the Libraries mailing list