Proposal: Add hasBitSize to Data.Bits.Bits

Ian Lynagh ian at
Wed Aug 22 23:19:29 CEST 2012

On Mon, Aug 13, 2012 at 06:42:54PM -0400, Edward Kmett wrote:
> class Bits b where
>     perhapsBitSize :: b -> Maybe Int
>     ...
> I am not wedded to the perhapsBitSize name

I've lost track of where this proposal is, but if we do end up with a
Maybe function then I think it should be called maybeBitSize or
bitSizeMaybe. The only analogous example in the core libraries that I
can think of OTTOMH is Text.Read.readMaybe.


More information about the Libraries mailing list