Proposal: adding 'tailDropWhile' to Data.List

Kazu Yamamoto ( 山本和彦 ) kazu at
Thu Sep 29 06:01:31 CEST 2011

>> I don't have an opinion on whether or not this should go in, but if the
>> proposal is accepted, the name of the function should follow the existing
>> Haskell Platform precedent from the "text" package, and be "dropWhileEnd"
>> instead of "tailDropWhile".
> I agree with Bryan regarding the name (though I'm still dubious as to
> whether it should be in Data.List).

I agree with the name too.


More information about the Libraries mailing list