Proposal: Add {to, from}Strict conversion functions between strict and lazy ByteStrings
Bas van Dijk
v.dijk.bas at gmail.com
Sat Oct 29 14:18:38 CEST 2011
On 29 October 2011 12:05, Herbert Valerio Riedel <hvr at gnu.org> wrote:
> I propose to add optimized {to,from}Strict conversion functions between
> strict and lazy ByteStrings to the Data.ByteString.Lazy API.
+1
Maybe this is bikeshedding and I'm not sure I like it but we could
also rename these functions to:
toStrict -> fromLazy
fromStrict -> toLazy
Because we nowhere mention the word 'strict' in the bytestring API but
we do mention to word 'lazy'.
Any idea why "toStrict/simple #1" is faster than "toStrict/optimized #1"?
Regards,
Bas
More information about the Libraries
mailing list