incorrect dependencies on template-haskell

Brandon Moore brandon_m_moore at
Mon Oct 3 03:31:06 CEST 2011

template-haskell- has inaccurate dependencies thatlead cabal-install to attempt to install it on 6.12.3 

The .cabal specifies

    build-depends: base >= 4.2 && < 5,

but assumes TypeSynonymInstances in PprLib.hs

(only true by default after Haskell2010 became default in ghc-7.0.1),

instance Show Doc

and PPr.lhs

import GHC.Show( showMultiLineString )
(added in commit e8d11b1, labeled

It seems the dependency should be at least base >= 4.3,
and either the LANGUAGE pragma or cabal file updated.

If the package isn't meant to be upgraded, should it be on
hackage at all?


More information about the Libraries mailing list