marlowsd at gmail.com
Wed Mar 30 12:29:18 CEST 2011
On 30/03/2011 10:58, Simon Meier wrote:
> In the 'bytestring' library, String handling based on this encoding is
> provided by the Data.ByteString.Char8 module and its lazy cousin.
> Therefore, I'd suggest to name this non-standard (or is there a
> standard?) encoding
> char8 :: TextEncoding
> Apart from historical reasons, I also prefer this name as it conveys
> more information about its semantics.
There's a clash here as we already use the term "binary" elsewhere in
the System.IO API: openBinaryFile, hSetBinary. So, it's not clear to me
that being consistent with Data.ByteString is better than being
consistent with System.IO. On the other hand, "char8" is a better name
than "binary". I don't feel strongly either way here.
More information about the Libraries