Help understanding a dependency conflict
lemming at henning-thielemann.de
Fri Jan 7 21:47:23 CET 2011
On Fri, 7 Jan 2011, tsuraan wrote:
> I have a program that's using both json (0.4.4) and hslogger (1.1.0).
> During the "cabal configure" stage of compiling my program, I get this
> error message:
> Warning: This package indirectly depends on multiple versions of the same
> package. This is highly likely to cause a compile failure.
> package json-0.4.4 requires mtl-18.104.22.168
> package hslogger-1.1.0 requires mtl-22.214.171.124
> Looking at the .cabal files for json and hslogger, they both have
> dependencies on "mtl", but neither package gives a version for it. I
> only have mtl 126.96.36.199 installed, so installing json didn't bring in an
> old version of the library when it was installed. My program compiles
> and runs without any errors. Can anybody tell my why cabal thinks
> json needs mtl 188.8.131.52, and what I can do to make the message go away?
Does any of the packages, that json and hslogger depend on, has more
restricted version dependencies?
More information about the Libraries