Installation question: cpphs, unix, and HEAD

Malcolm Wallace malcolm.wallace at
Fri Sep 3 13:34:36 EDT 2010

This line:

>> cabal: cannot configure unix- It requires base ==4.2.*

seems not to square up with the installed database:

>> >~/ghc-head/bin/ghc-pkg list
>> /Users/kfisher/ghc-head/lib/ghc-6.13.20100831/package.conf.d:
>>    base-
>>    ...
>>    unix-

which suggests that the HEAD's libraries are misconfigured.  The unix  
package has an explicit dependency on base-4.2.*, yet no base-4.2.* is  
installed (only base-4.3.*).  Probably the HEAD's unix.cabal file  
needs to bump the permissible dependencies up a bit.


More information about the Libraries mailing list