Proposal: Don't require users to use undefined

Stephen Tetley stephen.tetley at
Tue Oct 26 15:36:02 EDT 2010

Small bit of bikeshed...

Isn't Tagged also the so-called strip / stripping functor? a.k.a the
opposite of the Const functor.

Personally I'd prefer the name Strip. To me, the name Tagged is
suggestive of adding something to a data type. I suppose it is adding
something to a type constructor, but I'd still vote for Strip as it
seems more "twinned" with Const.

More information about the Libraries mailing list