RFC: Adding a Hashable type class and HashMap/HashSet data types
thomas.dubuisson at gmail.com
Thu Nov 18 19:20:29 EST 2010
Daniel Peebles <pumpkingod at gmail.com> wrote:
> I like this idea. As I mentioned on IRC, I'd call the class Hash rather than
The crypto-api already uses the class "Hash" for cryptographic hashes.
If you are talking about data to be hashed, and not the algorithm to
do the hashing, then "Hashable" is both correct and unique.
> I'm also with you on the Word return type. It may be less
> convenient but maybe this will be a tiny step towards the "great Word
> revolt" (in which all conceptually unsigned things in the prelude and
> standard libraries actually become unsigned) that I hope will occur sometime
> in the near future.
Whats next, making sure all bounded things don't flow over/under?
More information about the Libraries