Proposal: Add these two handy functions to Data.List

Bryan O'Sullivan bos at
Thu Jul 8 17:31:01 EDT 2010

On Tue, Jul 6, 2010 at 8:54 PM, Duncan Coutts
<duncan.coutts at>wrote:

> The one we discussed more recently is similar to what you are proposing
> now. I think the difference was that in what I suggested, the middle
> component of the tuple went to the end of the text, i.e. it was a prefix
> of the last component.

Right. I don't suppose there's a huge difference between the two, though the
simpler formulation has the added advantage of working "out of the box" with
those doughty and reliable warhorses of introductory FP, fst and snd.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Libraries mailing list