Bug in Parsec.Token

Don Stewart dons at galois.com
Tue Feb 16 20:04:05 EST 2010

> > I've applied the 2.1 patch to
> >    http://darcs.haskell.org/old-from-monk/parsec/
> > but I think that is unmaintained now.
> Thanks Ian!
> Unmaintained, eh?  Are people migrating to Parsec 3.0?  Last
> discussion I heard about that (many months ago), Parsec 3.0 had some
> performance issues when used as a drop-in replacement for 2.1.  I
> notice that Haskell Platform ships with 2.1 and that the RWH chapter
> stays within the subset of 2.1.  Anyone know if the Haskell Platform
> is changing to 3.0 in the next release?

The gitit team *won't move to parsec 3 because it is too slow*.

I vote the HP doesn't move either.

In fact, parsec-3.x should be the parsec3 package, and out of the
business of breaking our dependency chains.

More information about the Libraries mailing list