Problem installing unix-

Antoine Latter aslatter at
Sun Apr 4 10:46:24 EDT 2010

Hi Libraries,

cabal-install  tries to pull in unix- in it's install plan when
installing cabal-install, but it doesn't successfully install for me
under Ubuntu 9.10.

Here's some cut'n'paste of what I've tried:

$ cabal unpack unix-
Downloading unix-
Unpacking to unix-

$ cd unix-

$ cabal install
Building unix-

     error: Signals.h: No such file or directory
cabal: Error: some packages failed to install:
unix- failed during the building phase. The exception was:
ExitFailure 1

$ find . | grep Signals

unix- seems to have the same problem, and cabal-install can't
form a valid install plan for unix- I have hsc2hs in my path
at version 0.67, and I'm using GHC 6.12.1. Is there some step I'm


More information about the Libraries mailing list