Proposal: add new function "check" to Control.Monad
jon.fairbairn at cl.cam.ac.uk
Thu Sep 17 11:10:51 EDT 2009
Edward Kmett <ekmett at gmail.com> writes:
> While I like the generic version of filter, and have written one myself, I
> am somewhat concerned about the fact that Control.Monad is probably the
> module most often imported unqualified and without an explicit import list
> due to the sheer number of combinators that it provides and filter is a very
> commonly used function in the Prelude.
> Adding the generic version of filter with the same name to such a module
> will likely break a good deal of code.
I don't think it would break the code as such: it does exactly the same
thing. It would break the import declarations, though.
> Jon's suggestion of mfilter (filterM?)
Definitely mfilter. filterM is there already, and does what its name
implies. See proposal #3524.
More information about the Libraries