Proposal #3339: Add (+>) as a synonym for mappend
ross at soi.city.ac.uk
Thu Sep 17 09:37:48 EDT 2009
On Tue, Jun 30, 2009 at 02:37:51PM -0700, Bryan O'Sullivan wrote:
> Ticket: http://hackage.haskell.org/trac/ghc/ticket/3339
> From the ticket:
> This proposal was, I think, originally suggested by Jules Bean. The
> idea is to add two functions to the Data.Monoid module, (+>) and (<+),
> corresponding to different uses of mappend. These should not be methods
> of the Monoid typeclass, but top-level functions.
> I hope (but slightly doubt) that the visual nature of the two operators
> might help to counter the thought that monoids are just for gluing
> things together.
This proposal seems to have got stuck. Everyone wants an infix operator,
but we can't agree what it should be.
I prefer using a new operator instead of generalizing ++ (or +, *, &&
or ||), because I think that a monoid operation is so abstract that it
needs a name that doesn't suggest one of the special cases. (I like <>)
More information about the Libraries