Proposal: add new function "check" to Control.Monad

Martijn van Steenbergen martijn at
Thu Sep 3 07:02:47 EDT 2009

David Menendez wrote:
> I'm usually opposed to adding small functions to the standard library,
> but check is something I've defined for myself dozens of times.
> (Although I usually call it "require".)

Some languages call it "assert".


More information about the Libraries mailing list