GHC 6.12 + zlib + Mac OS 10.6

Manuel M T Chakravarty chak at
Sun Nov 29 22:08:42 EST 2009

Antoine Latter:
> On Sat, Nov 28, 2009 at 3:54 PM, Yusaku Hashimoto <nonowarn at> wrote:
>> I think you installed zlib without proper flags to link with 32-bit
>> libraries. configuring with ./Setup configure
>> --with-hsc2hs='--cc-flag=-m32 --ld-flag=-m32' should do the tricks.
>> See also
>> HTH
>> -~nwn
> The following worked like a charm:
> cabal install --hsc2hs-options='--cc-flag=-m32 --ld-flag=-m32'

Which version of 6.12 are you running?  These options or manually patching the hsc2hs wrapper should not be necessary with 6.12 anymore.  (They are only a temporary workaround to use the old 6.10 release on Snow Leopard.)


More information about the Libraries mailing list