Platform policy question: API compatability in minor releases

Bryan O'Sullivan bos at
Sun May 10 11:15:15 EDT 2009

On Sun, May 10, 2009 at 6:05 AM, Duncan Coutts
<duncan.coutts at>wrote:

> It's a good point though I would resolve it differently. I would suggest
> that we make it so that you don't actually have to upgrade to each minor
> bug fix release if the first one you picked worked ok for you. Then we
> only ask users and distros to upgrade (and thus rebuild everything)
> every 6 months (or perhaps 4).

Okay. I do somewhat suspect that you're making rather a lot of work for
yourself in that case with all those minor releases that probably won't see
much use, but far be it from me to suggest how you should spend your time

Overall, I'm very happy with this approach, and with your readiness to
engage in substantive discussion around API stability, scheduling, and the
like. Thanks so much for your great work!
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Libraries mailing list