Proposal: Add sequenceWhile and SequenceWhile_ to Control.Monad

Daniel Gorín dgorin at
Sat May 9 17:45:55 EDT 2009

On May 9, 2009, at 4:47 PM, Sittampalam, Ganesh wrote:

>> I'd be happy with the composition of two library functions *provided*
>> I can get hold of the value of the last run action.
> I think the While name needs to change, in that case. I can't think  
> of a
> nice sounding alternative though :-(

what about "sequenceUntil"? (of course, sequenceUntil p as ==  
sequenceWhile (not . p) as)

FWIW, I too think a function like sequenceWhile or sequenceUntil would  
be a convenient addition


More information about the Libraries mailing list