zlib and dependencies in general

Iain Barnett iainspeed at gmail.com
Tue Jun 30 19:08:09 EDT 2009

2009/6/30 Don Stewart <dons at galois.com>

> Perhaps the Haskell Platform would be helpful here to get you
> bootstrapped?
>    http://hackage.haskell.org/platform/
> Pre-built binaries for the main toolchain for a good number of systems.
> -- Don

Thanks for the link.

Unfortunately, the OSX only works for Leopard, and I initially used the
Debian package for GHC (6.8.2) and Hugs but no cabal-install in there, and
then used  source to get GHC6.8.3. I still can't get cabal-install on.

I think the main point though is that Cabal and cabal-install are not
straightforward to install (I must be pretty close to trying all versions by
now), and the packages they require aren't always straight forward to
install, which is why I think more, human readable, dependency information
could be shown on Hackage.

I'm already sold on using Haskell so I'm persevering, but I think anyone who
was just interested and had this trouble would have given up long ago, and
likely you wouldn't have heard from them.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/libraries/attachments/20090630/9cc4a099/attachment-0001.html

More information about the Libraries mailing list