Three patches for cabal

Duncan Coutts duncan.coutts at
Thu Jun 4 20:31:06 EDT 2009

On Thu, 2009-06-04 at 08:43 +0100, Simon Peyton-Jones wrote:
> I'd be quite happy to rename the flag to GeneralisedisedListComp, and
> clarify the user manual.  Would that suit everyone?
> I suppose the alternative is to leave it as TransformListComp, and
> document that fact.  But I rather agree that GeneralisedListComp fits
> the literature better.

Looking at the paper, it doesn't really give it any specific name.
Perhaps is a good thing because we can change the ghc user guide
relatively easily, but not published papers.

I appreciate Max's point that GeneralisedListComp is a bit vague, though
TransformListComp doesn't really speak to me. I would not (and did not)
guess it has any relation to the extension in question. My only other
suggestion is QueryListComp or GeneralisedQueryListComp (bikeshed
dangers approaching...).

The main point is that the docs and the extension name should be
consistent (and should refer to each other).


More information about the Libraries mailing list