Proposal #3271: new methods for Data.Sequence

Evan Laforge qdunkan at
Sun Jul 19 21:57:02 EDT 2009

> Again, I'd like to propose a compromise: make Data.Sequence.sortBy cmp be
> either fromList2 . Data.List.sortBy cmp . toList, or use the stable
> pairing-heap sort, and add a second sorting method, sortBy', that is
> unstable but faster.

Sounds good to me but how about calling them unstableSortBy and unstableSort?

More information about the Libraries mailing list