Policy question re: Haskell Platform installer on OSX

Yitzchak Gale gale at sefer.org
Wed Jan 14 06:49:58 EST 2009

I wrote:
>> In particular - there could be significant differences between
>> Leopard and Tiger...

Duncan Coutts wrote:
> Tiger   == OS 10.4
> Leopard == OS 10.5
> So the one built on 10.5 did not work with 10.4, but presumably an
> installer built on the older version will work on the newer version.

No, they are just incompatible. There are knotty differences
between the C library structures on the two platforms. And
there are differences in the installation paths. I suppose
you also have to watch out for PPC vs. Intel.

I can't say exactly what all those differences are though.

You can download an environment that lets a developer
working on Leopard set up installation packages for Tiger.
But Manuel told me that he was unable to use it, because he
couldn't re-use his work on the Leopard installer there.
He would have to start from scratch.


More information about the Libraries mailing list