Broken dependencies on cabal install haddock

Duncan Coutts duncan.coutts at
Wed Feb 4 18:54:55 EST 2009

On Thu, 2009-02-05 at 00:03 +0100, David Waern wrote:
> 2009/2/4 Ross Paterson <ross at>:
> > On Wed, Feb 04, 2009 at 10:52:32PM +0000, Dave Tapley wrote:
> >> dave at eliza:~$ cabal install haddock
> >> Resolving dependencies...
> >> cabal: cannot configure haddock-2.4.1. It requires ghc >=6.8.2 && <6.13
> >> There is no available version of ghc that satisfies >=6.8.2 && <6.13
> >> dave at eliza:~$ ghc --version
> >> The Glorious Glasgow Haskell Compilation System, version 6.8.2
> >
> > There is also a library package called ghc.
> Which should be installed if you have the compiler. Hmm.

If the package is broken due to missing dependencies then cabal-install
ignores it. It's on my TODO list to make it report more clearly the fact
that it needed a package that is broken (ie instead of removing the
broken packages from the set of installed packages, add a constraint not
to use that version and when we get a constraint conflict with we can
report a more helpful message).

Dave, you can confirm if the ghc package is broken by running ghc-pkg


More information about the Libraries mailing list