Proposal: add new function "check" to Control.Monad

Jon Fairbairn jon.fairbairn at
Wed Aug 26 14:07:43 EDT 2009

On 2009-08-26 at 09:49PDT Iavor Diatchki wrote:
> Hello,
> I don't really think that we need this function, it is plenty easy to
> just write with "guard". 

See my response to Sebastian, but also, none of the definitions
of check in terms of guard meet my criteria for being simple
enough, namely no lambdas and only a small amount of plumbing
(ie don't get round the "no lambdas" part by compiling it to S
and K ;-)

> Furthermore, if you choose to add it, then please do not use
> "check" for the name. This is way too generic a name which I
> often use for local functions that do some validation.

I was unsure of the name, for that very reason, so am open to


Jón Fairbairn                              Jon.Fairbairn at

More information about the Libraries mailing list