Proposal: rename Data.Map.fromAscList to Data.Map.unsafeFromAscList

Bulat Ziganshin bulat.ziganshin at
Fri Apr 24 09:13:18 EDT 2009

Hello Christian,

Friday, April 24, 2009, 5:10:57 PM, you wrote:
> fromAscList is total but may badly destroy the internal (invariant of
> the) representation. head at least crashes (hopefully fairly soon) when
> called wrongly.

well, using id for list sorting may also give wrong result. that's
implied by its name, not it?

Best regards,
 Bulat                            mailto:Bulat.Ziganshin at

More information about the Libraries mailing list