Splitting SYB from the base package in GHC 6.10

Ian Lynagh igloo at earth.li
Tue Sep 2 19:13:13 EDT 2008

On Wed, Sep 03, 2008 at 12:54:16AM +0200, Sean Leather wrote:
> On Wed, Sep 3, 2008 at 00:32, Ian Lynagh wrote:
> > On Tue, Sep 02, 2008 at 11:21:10PM +0100, Ross Paterson wrote:
> > > syb need no longer be a boot package.
> >
> > If base3-compat comes with GHC then syb must too.
> >
> So, it would still need to be a boot package. However, if base3-compat
> depended on the specific release version of syb (i.e. == instead of >=),
> then we could still install a newer version of the syb package with a
> different API and not break base3-compat, correct?

The binary base3-compat will depend on a specific version of syb, so you
can also install a newer version without breaking base3-compat, yes.


More information about the Libraries mailing list