Cabal on Debian Stable/GHC 6.6

Duncan Coutts duncan.coutts at
Tue Jun 24 05:57:40 EDT 2008

On Tue, 2008-06-24 at 10:51 +0200, Jochem Berndsen wrote:
> Hi,
> On a Debian stable (etch) system, I have the following packages
> installed:
> jochem at huygens:/tmp/Cabal-$ dpkg -l | grep ghc
> ii  ghc6                              6.6-3

Ok, so that's actually ghc-6.6 not 6.6.1

> jochem at huygens:/tmp/bimap-0.2.2$ runghc Setup.lhs configure
> Configuring bimap-0.2.2...
> Setup.lhs: ghc version >=6.4 is required but the version of /usr/bin/ghc
> could
> not be determined.
> jochem at huygens:/tmp/bimap-0.2.2$

> Cabal seems to be working. What am I doing wrong? Or is this an
> unsupported combination?

It's an untested combination. I checked it with 6.6.1 but not 6.6.

It is supposed to work (indeed it's supposed to work with 6.4) so we
should figure out what's going wrong.

Can you :
$ runghc Setup.lhs configure -v3

It should give more detail about how Cabal called ghc and what string
value it returned.


More information about the Libraries mailing list