Cabal-1.4: library-dirs and include-dirs missing from package description after install

Duncan Coutts duncan.coutts at
Fri Jun 20 05:42:34 EDT 2008

On Fri, 2008-06-20 at 10:19 +0100, Alistair Bayley wrote:
> 2008/6/19 Duncan Coutts <duncan.coutts at>:
> >
> > Ok, so the issue is that only the autoconfUserHooks looks for .buildinfo
> > files. The assumption was that configure scripts would want to write
> > a .buildinfo file while Setup.hs scripts can do it directly without
> > needing to go via any file.
> >
> > So probably the easiest thing to do is to use the autoconfUserHooks
> > anyway and make sure you override postConf otherwise it'll try to find
> > a ./configure script to run.
> >
> > The reason I couldn't reproduce it before of course is that I was making
> > assumptions about what you were doing and using autoconfUserHooks :-)
> Well, partly my fault. I was using defaultUserHooks, but this is now
> marked as deprecated, so I changed it to simpleUserHooks. Make a
> change, something breaks, is there a connection? :-)

Yep. defaultUserHooks was completely misleading as it was not the
default. (!!?!) Yes, you might reasonably have expected that
  defaultMain = defaultMainWithHooks defaultUserHooks
but no. defaultUserHooks was actually really autoconfUserHooks except
that if a ./configure script was not found it did not complain. This
caused confusion all round (especially for packages that really did need
a ./configure but where ./configure was not executable eg because it was
from a darcs repo or because it had to be generated with autoconf).

> We were always overriding the postConf hook, so using
> autoconfUserHooks as a defaultUserHooks replacement seems to work.



More information about the Libraries mailing list