Proposal: new version of getModificationTime

Ian Lynagh igloo at
Fri Jan 11 11:44:19 EST 2008

On Thu, Jan 10, 2008 at 11:56:37PM +0100, Felix Martini wrote:
> Hello all,
> Function getModificationTime in System.Directory returns ClockTime.
> ClockTime is part of the old-time package. The (new) time package has
> UTCTime, so i propose a new version of getModificationTime that
> returns UTCTime instead. I am not sure what a good name for the new
> version would be, perhaps getModificationUTCTime?

If we do add it with this name, then I think we should also add
getModificationClockTime and mark getModificationTime as deprecated.
Then we can change the type of getModificationTime at a later date.

(by the way, note that Directory.getModificationTime is in Haskell 98)


More information about the Libraries mailing list