cabal-install sends invalid proxy password

Dominic Steinitz dominic.steinitz at
Wed Dec 17 05:17:32 EST 2008

Valery V. Vorotyntsev <valery.vv <at>> writes:

> Dear lazy programmers,
> I was surprised to discover that `cabal-install' -- a popular utility
> for installing Hackage packages -- cannot work with HTTP proxies.
> Despite all the necessary code linked in.
> `cabal update' command returns HTTP 407 (Proxy Authentication Required)
> error.  The problem is explained below and patches follow.

I just tripped over the same problem yesterday so your patch saved me a lot of 


More information about the Libraries mailing list