More on Proposal #2717: Add nubWith, nubOrd

Yitzchak Gale gale at
Tue Dec 2 06:18:38 EST 2008

Bart Massey wrote:
> The patches implement Set.nubOrd and IntSet.nubInt, and modify the documentation
> for List.nub.

Could you please call it IntSet.nubOrd instead?
The namespaces of Set and IntSet should be compatible
wherever possible, so that you can just change the import
statement (and perhaps a type signature) to switch between them.


More information about the Libraries mailing list