proposal #2517: remove 'pure' method from Arrow class

Ashley Yakeley ashley at
Sat Aug 16 04:06:29 EDT 2008

David Menendez wrote:

> Personally, I prefer 'pure' to 'arr' for arrows, and I wish we could
> have called the operation in Applicative something different, but it's
> too late for that.

Hopefully one day the Applicative function will be called "return".

-- Ashley

More information about the Libraries mailing list