Proposal: add laziness to Data.Map / IntMap
Sittampalam, Ganesh
ganesh.sittampalam at credit-suisse.com
Tue Aug 5 11:12:39 EDT 2008
> Which naming scheme is less ugly,
> Data.Map.mapWithKeyL or Data.Map.Lazy.mapWithKey?
A separate module is much better, as it will allow switching entire
modules over just by changing an import, and still allow something close
to the mapWithKeyL usage via a qualified import (e.g. "import qualified
Data.Map.Lazy as L")
Ganesh
==============================================================================
Please access the attached hyperlink for an important electronic communications disclaimer:
http://www.credit-suisse.com/legal/en/disclaimer_email_ib.html
==============================================================================
More information about the Libraries
mailing list