Proposal: overhaul System.Process

Simon Marlow marlowsd at
Tue Apr 22 19:35:22 EDT 2008

Duncan Coutts wrote:

> Do you suppose we can rename the system/rawSystem given that we're
> already moving them from one module to another?
> Just off the top of my head, how about "runShellCommand" & "runProgram",
> better suggestions welcome.

Well, ideally we'd do a complete renaming sweep, e.g. runProcess should 
be spawnProcess (or just removed entirely), then we could use runProcess 
for what is currently called rawSystem.  But I've got enough flak for 
changing APIs in the past so I wimped out this time :-)

runShellCommand for system is not good, because we already have 
runCommand which  is the same except that it doesn't wait for 
completion.  Something like runProcessAndWait would make sense, perhaps, 
but that's a mouthful.


More information about the Libraries mailing list