[Haskell] Re: Trying to install binary-0.4

Isaac Dupree isaacdupree at charter.net
Mon Oct 29 09:30:30 EDT 2007

Simon Marlow wrote:
> Now, when GHC 6.10 is released, the majority of these packages will 
> build again if the .cabal file is changed to say
>   build-depends: base >= 3.0 && <= 3.1
> rather than introducing conditional dependencies as was necessary with 
> the recent base split.  In due course, packages can be upgraded to 
> depend on the new base-4.0.
> I'll call this proposal 4.3 and add it to the wiki.  It seems like a 
> pretty good compromise to me.

yay, a good naming proposal!  This explains what I meant by the thing 
with macros - of course it cannot provide base-2.0, but it provides 
something close to that base API, such as you would expect from a 
version number increase.

what if the ghc 6.8 branch's base has to change enough that it needs to 
be incremented to 3.1 by PVP? Or maybe that should never happen.

but, oh, the .cabal file should be changed _after_ the release of 6.10 
(so that it will be accurate) (otherwise it might be >= 3.0 && < 4) so 
we'll know what the version numbers are (as long as we never do a point 
release of a previous GHC branch, once "3.1" has been taken by 6.10's 
base)  It could be "3.5"... but then that theoretical 3.1 would be 
considered a valid dependency even if it contained different API changes 
that broke things... so, okay


More information about the Libraries mailing list