Bumping "extralib" library versions

Ian Lynagh igloo at earth.li
Mon Oct 22 20:57:40 EDT 2007

On Mon, Oct 22, 2007 at 02:11:03PM +0100, Ian Lynagh wrote:
> We've discussed this in #ghc, and we think it's best to use 4 component
> version numbers so Cabal's snapshot (== append $date) version numbers do
> what we want and fit in with us following the proposed policy.

Just to clarify, what I meant by this is:

    Given we are going to use the a.b.c.d scheme where a.b is the major
    API, we should use version numbers like rather than 2.1

(I wasn't aware of anyone being against the a.b.c.d scheme when I wrote
the original mail).

If instead we decide to use a.b.c where a is the major API, then we
should use 2.1.0 instead rather than 2.1.

We do actually need to pick one or the other really quite quickly for
the GHC 6.8.1 release, although I don't think getting it wrong and
changing our minds later will cause any major problems. My impression
from those opinions I've read is that 4-component is more likely to be
the concensus.


More information about the Libraries mailing list