META-PROPOSAL: Documentation should be required to say when exports were introduced

Bulat Ziganshin bulat.ziganshin at
Sat Nov 17 10:53:18 EST 2007

Hello Ian,

Saturday, November 17, 2007, 5:13:18 PM, you wrote:

> it tells you that file_get_contents is available in PHP >= 4.3.0.

> I propose that all exports in Haskell libraries should be required to
> have such a thing in their haddock documentation.

may be we should construct a "Good Library" policy which includes reqs
to "well-behaved" or mat be "haskeller-fiendly" lib? in particular,
these rules should be required for any lib included in Haskell
Standard (as i proposed)

Best regards,
 Bulat                            mailto:Bulat.Ziganshin at

More information about the Libraries mailing list