ANN: HSH 1.2.0

Neil Mitchell ndmitchell at
Fri Mar 9 13:12:31 EST 2007


> I note that the deadline for discussion of System.FilePath has now passed (well,
> a long time ago :-), so it looks like it's going into base.  Any final
> objections before we do this?

The deadline passed before Christmas, and no one objected. I still
intend to move it in to base, I just haven't had the time to put
together a patch. The code needs tweaking a bit before it goes in.

> Regarding canonicalizePath, I'd be perfectly happy to change its name and/or
> somehow make it more easily discoverable: does anyone want to make a proposal?

I recommend either changing the name to unportableGHCCanonicalizePath
or implementing it for Hugs ;)

I can't think of a good name, FilePath originally called it
makePathAbsolute, but I'm not convinced that is any better. Maybe if
the documentation refered to the fact it makes the file path absolute
it would be better.

I do think canconicalPath would be an improvement though, the ise/ize
is confusing enough when writing English, having it in Haskell is
annoying, and requires me to think every time.



More information about the Libraries mailing list