Supported Windows versions (was: Re: unix package)

Bulat Ziganshin bulat.ziganshin at
Sun Jul 1 10:12:08 EDT 2007

Hello Esa,

Saturday, June 30, 2007, 9:28:49 PM, you wrote:

> Maybe this is a good place to ask for opinions.  Anyone have any or know of
> need to support old Windows versions?  I am also curious if someone still
> writes software for pre-Windows 2000 NTs, as there's some nice API functions
> in Windows 2000.

i write a general-purpose program (archiver) and will prefer to have
it win9x-compatible. btw, this doesn't have any relation to the fact
that ghc itself can be run on old OSes

regarding i/o library, it will be great to make it independent of GHC
RTS, as Streams does

Best regards,
 Bulat                            mailto:Bulat.Ziganshin at

More information about the Libraries mailing list